Instalando o novo Wine 1.5.6 no Ubuntu via PPA

winelogoofc2
Share
banner

Uma nova versão do famoso emulador de ambiente Windows para Linux, o Wine, foi lançada trazendo algumas novidades interessantes.

Dentre as várias mudanças e correções para esta versão (que você pode conferir a lista completa aqui), ressaltamos o suporte a processamento de vídeo com o DirectX 9, ou seja, ficou muito mais fácil de rodar jogos nativos do Windows no Linux, via Wine.

Para instalá-lo no seu Ubuntu via PPA, abra um terminal e execute os seguintes comandos:

sudo add-apt-repository ppa:ubuntu-wine/ppa

sudo apt-get update

sudo apt-get install wine1.5

ATUALIZAÇÃO

A Versão 1.5.6 do Wine é ainda uma versão de desenvolvimento (segundo diz o próprio site do projeto http://www.winehq.org/download).

Quando fiz a matéria, os desenvolvedores haviam disponibilizado o pacote 1.5.6 para download via PPA (no Launchpad) e agora realmente ele não está mais disponível neste repositório. Assim que a equipe do Wine atualizar o repositório PPA, aviso a vocês. Por hora, a última versão disponível é a 1.5.5

PUBLICIDADE


Quer continuar por dentro das novidades do Blog Seja Livre? Siga o nosso perfil no TWITTER, curta a nossa página no FACEBOOK ou adicione o Blog Seja Livre nos seus círculos do GOOGLE+. Se você usa ORKUT, nós também estamos lá, inclusive no IDENTI.CA e Linkedin.

Sobre o Autor

Blogueiro, fundador do Blog Seja Livre, Nerd inveterado, louco por Linux e músico nas horas vagas. Atualmente é o Editor Chefe, Consultor de SEO e Webdesign do Seja Livre, e possui algumas certificações em Linux e Administração de Redes. É usuário Ubuntu e membro do LoCo Team Ubuntu-BR-SP e da Comunidade Ubuntu-BR.

  • lucas lourenco

    Quando eu tento instalar o wine no meu ubuntu acontece isso:
    Os pacotes a seguir têm dependências desencontradas:
    wine1.5 : Depende: wine1.5-i386 (= 1.5.22-0ubuntu2) mas não é instalável
    Recomenda: gnome-exe-thumbnailer mas não será instalado ou
    kde-runtime mas não será instalado
    Recomenda: ttf-droid
    Recomenda: ttf-umefont mas não será instalado
    Recomenda: ttf-unfonts-core mas não será instalado
    Recomenda: winbind mas não será instalado
    Recomenda: winetricks mas não será instalado
    E: Não foi possível corrigir os problemas, você suspendeu pacotes quebrados.
    pq isso?

  • http://Seusite... Douglas Muratore

    Acho que este post está precipitado .. O Wine 1.5.6 foi lançado dia 8 de Junho (uns 5 dias atrás), enquanto o último upload na ppa do wine nos repositórios do ubuntu data de 3 semanas atrás.. Lendo as notificações no WineHQ, pode-se ler:
    “O código fonte está disponível agora. Pacotes binários estão em processo de construção e em breve estarão em suas respectivas sessões da área de downloads..”

    Creio que as instruções levem a qualquer usuário a instalar a versão 1.5.5 e, se checarem a versão de seu próprio Wine com “wine –version”, terão a mesma surpresa..

  • http://Seusite... Douglas Muratore

    Eu tentei de todas as formas que consegui pensar .. Mas a instalação acabou sempre na versão 1.5.5 ..
    Resolvi checar manualmente pra que endereço o ubuntu-wine/ppa mandava meu apt buscar o wine e entrei no endereço pelo navegador.. Sério, não existe wine1.5.6 lá (http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/pool/main/w/wine1.5/) .. E eu executo exatamente a mesma linha pra adicionar o app:
    sudo add-apt-repository ppa:ubuntu-wine/ppa

    Então sei lá .. Ou meu add-apt-repository tá muito doido ou há algum engano :(

    Gostaria de uma luz, agradeço desde já.

    • http://Seusite... Douglas Muratore

      “O código fonte está disponível agora. Pacotes binários estão em processo de construção e em breve estarão em suas respectivas sessões da área de downloads..”

      Desculpem-me, mas acho que se executarem o comando “wine –version” verão que é também a versão 1.5.5 .. Ao que tudo indica o pacote debian do wine1.5.6 ainda não está pronto – visto que o último pacote que subiram no ppa foi há 3 semanas e o 1.5.6 foi lançado no dia 8 – e este post leva o usuário a instalar o 1.5.5…

    • Vinícius Vieira

      A Versão 1.5.6 do Wine é ainda uma versão de desenvolvimento (segundo diz o próprio site do projeto http://www.winehq.org/download).

      Quando fiz a matéria, os desenvolvedores haviam disponibilizado o pacote 1.5.6 para download via PPA (no Launchpad) e agora realmente ele não está mais disponível lá.

      Assim que atualizarem o repositório, aviso a vocês.

  • http://twitter.com/hiper4tivo @hiper4tivo

    E quem já tá com o wine 1.5.5 instalado pelo mesmo repositório?

    Atualizei aqui meu sistema e a atualização do wine não rolou.

    #comofaz

  • Vinícius Vieira

    Olá RC Lages.
    Dois pontos a serem observados:
    1- O Wine 1.5.6 deve ser instalado via PPA, como mostra o artigo acima, e não diretamente (vc não especificou no seu comentário se habilitou o repositório PPA do Wine, por isso citei este ponto.)

    2- O erro que você apresentou não foi da instalação do Wine, repare na segunda linha onde diz:
    “Não foi possível encontrar o pacote “install”, e mais de 40
    pacotes contêm “install” em seu nome.”
    Por algum motivo o seu sistema, ao utilizar o aptitude, não reconheceu a variável “install”.

    Tente fazer a instalação como está mostrado na metéria que, com certeza, irá conseguir.
    E só pra esclarecer, o Wine 1.5.6 está disponível para arquiteturas i386 e amd64.

    Vlw!

    • http://twitter.com/hiper4tivo @hiper4tivo

      O problema com a questão do “install” foi a digitação. E sim, o aptitude está reconhecendo o install, porém se prestarmos a atenção ao comando que realmente foi digitado, veremos que é o seguinte:

      sudo aptitude install install wine1.5

      Ou seja, ele tem install “duas vezes”. O primeiro ele entende o comando, e no segundo ele ele interpreta como sendo uma biblioteca, que obviamente não existe.

      Outro detalhe, é que embora exista Wine para a arquitetura 64bis, é altamente recomendável utilizar a versão em 32bits. Mesmo que você tenha um ubuntu 12.04 64bits é possível e até mesmo recomendado instalar o Wine 32bits para melhor compatibilidade.

      Se tiver que instalar por exemplo o dotnet 2.0 na arquitetura 64bits você receberá um erro.

      É possível forçar essa inatalação? Pelo que soube sim, mas nunca fiz. É mais cômodo usar o 32bits.

      Como faz pra rodar o Wine 32bits em um ubuntu 64bits? Prometo fazer um post falando melhor sobre isso no meu blog, mas é possível achar isso buscando no Google também.

      • Vinícius Vieira

        Eu nem tinha reparado que haviam dois “install”… rs.

        Vlw!